Planilha Condicional, como somar as células pela cor?


#1

Bom dia.

Fiz uma planilha condicional, atribuindo um critério para que cada célula fique com uma cor. Agora preciso somar todas as células que estão com a cor vermelha, porém não estou conseguindo aplicar a função que criei no VBA, como consigo somar essas células desta planilha condicional?


#2

Boa tarde @Erica, já tentou usar =Somases com o mesmo critério da planilha condicional?


#3

Boa tarde Kelvin

Você pode me ajudar por favor?

Nas células com a formatação condicional, eu coloquei que para todas as células com o dia acima do dia 16 e para a mesma ficar vermelha, e no final eu gostaria de somar o número de células em vermelho


#4

Erica

Voce pode usar função SOMARPRODUTO selecionando as celulas onde esta a formatação e colocar a formula que usou para achar os dias > 16, se não souber fazer colocar a formula que fez na formatação condicional e tentarei fazer a formual

Decio


#5

@Erica Pode fazer da forma que o @deciog falou ou fazer =Somase “Coluna onde está as células” >16/05/2017

Caso não souber usar a formula Somase vai em Formulas>Matematica e Trigonometria>Somase. O Excel passa um caminho bem claro para usar.

Lembrando que se existir mais de 1 condição, tem que usar o SomaseS.

Att.

Kelvin Justino.


#6

Ola Kelvin

Grata pelo retorno.

Usei a função soma-se mas ela soma o valor dentro das células vermelhas, e só preciso que some as células com p fundo vermelho. Usei a fórmula conta.ses pois existe mais de um critério, mas deu erro.
Eu tenho que apresentar declarações até a data de vencimento que são de acordo com cada vez empresa.
Ex: empresa A vence vence dia 16 e se a declaração for apresentada dia 17, está em atraso e coloquei a formatação condicional para a célula ficar em vermelho indicando o atraso. Mas também tem a empresa B que vence dia 17 e assim por diante.

No final de cada mês eu preciso saber o total de empresas que foram entregues às declarações em atraso, por isso preciso da fórmula que conte apenas as células em vermelho.

Obrigada pela ajuda e atenção


#7

Olá @Erica,
Pelo que entendi você só tem um critério…que é a data de vencimento, e esta muda de empresa para empresa, porém o fato de serem datas diferentes inviabiliza o uso da função CONT.SE ou CONT.SES mesmo. Agora se puder criar uma coluna que tenha a seguinte fórmula:

=SE(“Célula_com_a_data_declaração”-“Célula_com_a_data_Vencimento”<0;“X”;"")

nesta coluna aparecerá um X toda a vez que a celula da coluna Data de Vencimento estiver VERMELHA, sendo assim, basta você contar a quantidade de vezes que o X aparece.usando a fórmula:

=CONT.SE(“Intervalo que aparecerá o X”;“X”)

Espero ter ajudado, mas se ficou confuso, posta uma imagem da planilha que eu coloco com as referência da sua planilha.

Abraço!


#8

Boa noite Kelvin

Mais uma vez obrigada por sua ajuda e atenção.
Compreendi a sua resposta, porem não estou conseguindo aplica-la na minha planilha, estou lhe enviando a planilha modelo com a mesma estrutura da que utilizo no trabalho, só os dados que se alteram.

Conforme vou apresentando as declarações de cada empresa, coloco o dia exato que apresentei na coluna correspondente ao mês e a partir da formatação condicional que fiz para cada célula ela me traz a cor AZUL para entregue no prazo e VERMELHO para entregue fora do prazo. Ao final de cada mês preciso saber quantas declarações foram entregues em atraso, ou seja, apenas as células pintadas em vermelho.

Se possível, peço a gentileza que demonstre para que eu possa aprender e executa

Obrigada mais uma vez


#9

Olá @Erica. Acho que a função CONT.SE resolve seu caso:

=CONT.SE(C21:C29;">18")

Depois nos diga se conseguiu fazer.


#10

Caro @xavier, não resolve, pois cada empresa tem um vencimento diferente.


#11

Cara @Erica, depois que você mandou a imagem percebi que a fórmula era mais complexa, mas o conceito era o mesmo… só fiz duas alterações:

1° Alteração na lista de empresas deixando cada uma em sua linha para a função ÍNDICE e CORRESP funcionarem corretamente;

2° Inserção das colunas de Condição, salientando que elas devem ficar ocultas. A coluna C deixei visível para que você pudesse ver a fórmula, entretanto ela também deve ser ocultada.

Segue a imagem, espero ter ajudado.
Qualquer coisa é só perguntar!


#12

Entendi, @exceldiretoaoponto.


#13

Como eu disse, use a legenda que o Somases te passa. Você tem mais de uma condição, tem Condição “Empresa” e condição “Data > Vencimentos”. Ficaria mais ou menos assim:

Empresa A e B

=SOMASES(“Coluna que quer somar”;Tabela1[EMPRESAS];EMPRESA A;Tabela1[MAIO DATA ENTREGA];">16")+SOMASES(“Coluna que quer somar”;Tabela1[EMPRESAS];EMPRESA B;Tabela1[MAIO DATA ENTREGA];">16")

Empresa C:

=SOMASES(“Coluna que quer somar”;Tabela1[EMPRESAS];EMPRESA C;Tabela1[MAIO DATA ENTREGA];">17")

Empresa D E F:

=SOMASES(“Coluna que quer somar”;Tabela1[EMPRESAS];EMPRESA D;Tabela1[MAIO DATA ENTREGA];">18")+SOMASES(“Coluna que quer somar”;Tabela1[EMPRESAS];EMPRESA E;Tabela1[MAIO DATA ENTREGA];">18")+SOMASES(“Coluna que quer somar”;Tabela1[EMPRESAS];EMPRESA F;Tabela1[MAIO DATA ENTREGA];">18")


#14

Olá kelvin

Muito obrigada pela sua ajuda, fiz conforme falou, mas só coloquei a fórmula SE para a coluna Condição e depois apliquei a fórmula cont.ses e funcionou.
:grin:


#15

Olá @Erica, não há de quê!

P.S. A dica é do @exceldiretoaoponto e não do @KelvinJustino:sweat_smile: , Mas está valendo!

Grande abraço!


#16

E que aparece esse nome nas suas respostas kkkkkk


#17

Xavier, vc elabora planilha de orçamento personalizada? Eu tenho um modelo que quero interligar, pode me ajudar??


#18

Posso sim, @Fenicia. Mande um e-mail para exlplanilhas@gmail.com e a gente pode iniciar conversa por lá.