Posição do algarismo em distribuido em colunas


#1

Boa tarde pessoal!

Preciso de uma fórmula que encontre a posição do algarismo e distribua conforme a coluna pertencente. Veja o exemplo abaixo:

Desde já agradeço a ajuda!

Rogério!


#2

@ryoshitake, acho que assim resolve:

Começando pela C3:
=SEERRO(EXT.TEXTO($B3;NÚM.CARACT($B3)-CONT.VALORES(D3:$W3);1);0)

Na coluna W você pode remover o CONT:
=SEERRO(EXT.TEXTO($B3;NÚM.CARACT($B3);1);0)


#3

@xavier Deu super certo! Muito obrigado pela sua ajuda!