Problema com uma formula de uma planilha


#1

Boa tarde.
Preciso de uma ajuda Please:
Tenho uma tabela de compras (vermelho) e Vendas em (Azul)
Na coluna em Branco no campo quantidade, preciso fazer uma fórmula que me traga somente os Itens que foram comprados (vermelho), mas ainda não foram vendidos e estão no estoque, os outros não me interessa mais porque já não tem mais.
Pois bem, fiz a Fórmula =SE(E(P18=$AA$16:$AA$210000);"";SE(E(P18<>$AA$16:$AA$21000);P18))
Mas ele só funciona na terceira Linha onde tenho as duas informações iguais (Na mesma linha), e ainda não sei fazer como apagar estas informações uma vez que já foram concluídas.
O que preciso?
Como a Quantidade (do produto X) na linha 16 (Quantidade 1) já foi concluído a compra e a venda, não preciso mais do resultado. (mesmo ela estando em compras na linha 16 e em vendas na linha 17), conforme indica a flexa
Quantidade 2 (Linha 17) finalizado em vendas na linha (16) Deve-se excluir
Quantidade 3 (na mesma linha ) finalizado, (excluir)
Quantidade 4 (Esta quantid. Só foi comprada, mas ainda não foi vendida), está é a informação que preciso para o relatório ou o Filtro ou uma fórmula)
Quantidade 5 (Linha 20) já finalizado em vendas na linha (19) Deve-se excluir
Quantidade 6 (Esta quantid. Só foi comprada, mas ainda não foi vendida), está é a informação que preciso para o relatório ou o Filtro ou uma fórmula)


#2

Oi, @Edmar. Tudo bem?

Pelo que entendi você quer trazer o saldo dos itens que ainda estão em estoque e somente estes. Correto?

Acredito que não será possível conseguir esse resultado apenas com uma função do Excel (mesmo que matricial). Sendo assim, você precisará criar alguma lógica que, interpretada por uma função, gere o resultado esperado. É como criar um algoritmo. Se quiser que um desenvolvedor profissional dê uma olhada estudada no seu caso, mande um e-mail para exlplanilhas@gmail.com explicando a sua necessidade e enviando o arquivo. Assim podemos planejar o que pode ser feito.


#3

Se entendi direito seu problema, ela pode ser resolvido com o uso de uma coluna Auxiliar para localizar os itens que se repetem nas duas tabelas (Coluna em azul).
Depois é puxar os itens em ordem para a coluna de resultado (Coluna em verde) e buscar o restante para demais colunas (Coluna em amarelo). As fórmulas usadas estão abaixo. Caso não seja isto ou fique com dúvida meu e-mail é dirneinetto@hotmail.com.
image