Problemas com o Função Somase


#1

Estou com sérios problemas para conseguir fazer funcionar a função Somase. Segui todos os passos indicados na ajuda de montagem da função, mas ela não busca as informações como deveria. Estou montando um resumo para um fluxo de caixa onde na origem das informações encontro o mês correspondente à despesa e o valor, e o critério de busca é o mês.

=SOMASE(‘Contas a Pagar’!$EB$6:$EC$1961;J$5;‘Contas a Pagar’!$EC$6:$EC$1961)
Onde EB é a coluna do mês de ocorrencia do valor EC, J5 é o critério de busca do mês…


#2

Oi @HPach1, para a SOMASE funcionar ela precisa buscar os valores em uma única coluna e retornar valores de uma única coluna. No seu caso, você está pegando uma matriz com duas colunas EB:EC .

Basta alterar isso na fórmula que ela deve funcionar. Ficaria assim =SOMASE(‘Contas a Pagar’!$EB$6:$EB$1961;J$5;‘Contas a Pagar’!$EC$6:$EC$1961)


#3

Caro Rafael, Esta modificação eu já havia testado e não funcionou. Na realidade estou desconfiado de algum problema na formatação das células tanto de origem como de destino. Datas e Valores


#4

Essa é uma possibilidade de erro mesmo. Como você está lidando com datas, precisa se certificar que as buscas e valores procurados estão corretos.

Não sei se o exemplo que eu vou dar se aplica ao seu caso, mas o que eu costumo fazer quando estou buscando um mês no SOMASE é criar uma coluna auxiliar. Por exemplo, se a data 04/07/2017 está na coluna EB. eu crio uma nova coluna com a fórmula =MÊS(EB1) e arrasto. Nesse caso, o valor retornado seria 7. Depois, na célula com o critério, eu uso um PROCV ou SE para retornar o valor correto de acordo com o mês escolhido. Nesse caso, se eu colocasse Julho, teria uma tabelinha auxiliar para retornar o valor 7 e somar os valores relacionados a esse mês.

Espero ter ajudado e se continuar com dúvidas é só falar