PROCV com valores iguais


#1

Como tenho itens que tem a mesma quantidade, o excel sempre retorna o mesmo valor, como faço para retornar todos os valores ? Segue como está a planilha.

image


#2

Boa tarde @Leonardo,

a solução que te dei não serve?


#3

Boa tarde.
Não tinha visto que você havia respondido, desculpa!
Dei uma olhada no modo que você colocou, bem interessante, mas nele eu teria que já deixar os itens em ordem do maior para o menor e também não poderia ficar selecionando as células e sim deixar tudo automático.
Pelo o que eu estou pesquisando, acho que terei que usar corresp, indice…


#4

Leonardo boa Tarde!
Primeiramente tem que inserir uma coluna antes Para ser a coluna A

Em A2
=SE(B2<>"";1;"")
Em A3
=SE(B3<>"";1+A2;"")
Arraste para as outras celulas
Classificação
EM E2
=MAIOR($B$2:$B$6;A2)
Arraste para as outras celulas
Quant
Em D2
=SEERRO(PROCV(E2;$B$2:$C$6;2;0);"")
Arraste para as outras celulas

Espero ter ajudado