Pula final de semana (Sábado e Domingo) + 24 ou + 48h


#1

Bom dia amigos.

Alguém pode me ajudar por favor.

Tenho a segunda formula no excel

SE(A1="";"";SE(A1+6/24>(INT(A1)+18/24);(INT(A1)+1+8/24+(A1+6/24-(INT(A1)+18/24)));A1+6/24)))

Porém quando chega na sexta feira e a soma cai no sábado ela tem que somar mais 48 horas e quando a soma cai no domingo, ela tem que somar mais 24 horas, mas não estou conseguindo executar… Alguém pode me ajudar.

Eu tendei o seguinte

=SE(A1+6/24=DIA.DA.SEMANA.6;A1+48;SE(A1+6/24>(INT(A1)+18/24);(INT(A1)+1+8/24+(A1+6/24-(INT(A1)+18/24)));A1+6/24)))

Mas não deu.


#2

Bom dia… o que vc tem na célula A1 ? Qual o formato da sua célula A1 ?
Creio que seja mais ou menos isto que você queira:

=SE(DIA.DA.SEMANA(A1+6;2)=6;A1+8;SE(DIA.DA.SEMANA(A1+6;2)=7;A1+7;A1+6))

padrão 2 seria 6=sabado 7 = domingo

abs


#3

Boa noite amigo.

Vou te enviar um exemplo para você tentar me ajudar, já conseguiu tirar minha duvida, mas ainda não consegui chegar ao resultado, estou anexando um planilha como exemplo, fico grato pela força

Att,

Cleber.Exemplo.xlsx (10,5 KB)


#4

Bom dia Cleber… Entendi, vou dar uma olhada e assim que possivel te respondo. Segunda é um pouco corrido aqui na empresa.
abs


#6

@Cleber_Nego

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio
Exemplo Decio.xlsx (10,9 KB)


#7

Show Décio… Parabéns.
Abs


#8

Obrigado amigo… Ajudou muito. Grato