Qual é a fórmula que usaria para isso?


#1

Boa noite!
Queiram ajudar-me.
Tenho os seguintes valores: 1, 2, 3, 4 e 5. Cada célula só pode ter apenas um deles.
Quero verificar, na célula, se o número é par ou ímpar:
a) Se for par deve fazer a seguinte expressão: 5-x, onde: x é o tal número par;
b) Se for ímpar deve fazer a seguinte expressão: x-1, onde x é o número ímpar.

Obrigado!


#2

Olá, @secuwi. Tudo bem?

Em outra célula, (que não contém estes números):

=SE(PAR(A1)<>A1;A1-1;5-A1)

No exemplo imaginei seus números estando na linha 1.


#3

Muito obrigado ilustre Xavier!
Solução inteligente.


#4

Vc tb pode digitar A1=1, A2=2, A3=3, A4=4 e A5=5
Em B1 digite a fórmula: =SE(ÉPAR (A1:A5),5-A1:A5,A1:A5-1) após digitar a fórmula não digite ENTER mas CTRL+SHIFT+ENTER. A Fórmula aparecerá entre chaves: {=SE(ÉPAR (A1:A5),5-A1:A5, A1:A5-1)}
É uma fórmula matricial digitada uma só vez em B1 que será aplicada automaticamente em B1 à B5.