Qual fórmula, ou conjunto de fórmulas utilizar?


#1

Boa noite!

Preciso de uma fórmula Excel com a seguinte condição

terei um valor fixo, então o valor será analisado em 3 condições…

Exemplo

120 (valor fixo)
100 (referência)
R$ 50,00 (valor normal)
R$ 80,00 (excedente)
5% tolerância

O valor será comparado com a referência e

SE o “valor fixo” for menor ou igual a referência, será multiplicado o “valor normal” com a "quantidade referência"
Exemplo “valor fixo” estando entre 0 e 100 o resultado sempre será 100*50=5000 dando a condição de pagamento mínimo no valor de 5000 reais

SE o “valor fixo” for maior que a “referência” será analisada a “tolerância” calculada em cima da “referência” e CASO não exceda a “tolerância” o resultado final será o “valor fixo” multiplicado pelo “valor normal” dando a condição de não pagamento de excedente até 5% acima da referência, mesmo assim cobrando por cada “valor normal” acima da "tolerância.

Exemplo: “Valor fixo” 105, valor acima da “referencia” porém abaixo do limite “tolerância” então o valor será calculado (105 * 50) que totalizará 5250.

SE o “valor fixo” for maior que a “referência” ultrapassando a “tolerância” então será multiplicado a “referência” pelo “valor normal” e depois será subtraída o “valor fixo” da “referência” e cada valor acima da “referência” será multiplicado pelo “excedente”, dando a condição de que se for excedida a “tolerância” todo valor acima da referência será considerado “excedente”

Exemplo: “Valor fixo” 120, será cobrado no preço normal 100 e os 20 serão multiplicados pelo excedente

120 = 10050 + 2080 = 600

Resumindo… Terei um valor, que será comparado e SE for menor ou igual a referência será multiplicado pelo valor normal, e SE o valor fixo exceder a referência até 5% será multiplicado o valor fixo pelo valor normal, e SE o valor fixo exceder a tolerância, todo valor acima da referência será multiplicado pelo excedente…


#2

Fala, @Pagyell. Tudo bem?

Basta você aninhar as funções SE de acordo com os critérios. No exemplo coloquei os valores partindo de A1:

=SE(A1<=A2;A3*A2;SE(A2*(1+A5)<=A1;A1*A3;(A1-A2)*A4+A2*A3))

Utilizando os valores do exemplo, o resultado deu R$ 6.000.