Referência de argumento de função em célula


#1

Pessoal,

Pode ser que minha dúvida seja muito básica, mas eu estou com dificuldades.Embora a função que esteja usando seja CORRESP, o problema que encontro se estende às demais funções, por isso vou tentar explicar com uma função simples.
Tenho uma pasta de trabalho com duas sequências numéricas que eu selecionei de dei “nomes” (rótulos de matriz). Uma delas se chama “Tudo” e outra “Parcial”.
Em outra pasta de trabalho quero calcular a média destes valores, porém em uma mesma célula, ora tenho que apresentar o valor da média de “Tudo” e outra hora a média de “Parcial”.
Eu fiz uma função na célula A1 que a preenche com o nome “Tudo” ou “Parcial” conforme o caso, mas ao tentar usar essa célula como referência ao argumento da função MÉDIA que está na célula B1, não consigo o resultado.
Na célula B! está a função =MÉDIA(A1)
E na célula A1 está escrito “Tudo”.
Alguém pode me ajudar?


#2

@angelo.reami, tente com a função INDIRETO:

=MÉDIA(INDIRETO(A1))


#3

@xavier, muito obrigado pela ajuda. Eu já tinha tentado esta função, mas estava com a sintaxe errada!
Funcionou!