Remover zeros à esquerda


#1

Bom dia Pessoal,

Baixei uma planilha em Excel do site da Sefaz, o formato de número está tipo “000.000.000”,
porém preciso aplicar uma fórmula de procv onde os números na planilha estão em formato simples.
preciso remover os Zeros à esquerda e tirar os pontos, em seguida aplicar a fórmula de busca.

Como faço para que ambas tabelas fiquem iguais para que possa efetuar a busca?

Por exemplo: na primeira planilha tenho esse número " 000.0102.789"
Na segunda Planilha tenho o número 102789

Tentei aplicar a fórmula de Substituir para remover os pontos, porém a fórmula do Procv não lê a célula de fórmula.

Preciso muito dessa ajuda!
alguém pode me dá uma ideia?


#2

Voce pode colocar desta forma

=PROCV(VALOR(ARRUMAR(SUBSTITUIR(A1;".";"")));celula onde procurar;numero;verdadeirou ou falso)

Decio