Retornar valor de célula em data específica


#1

Bom dia a todos,

Alguém sabe se existe fórmula que retorne o valor de uma célula em uma data específica?
Por exemplo:
Quero que a célula A2 retorne o valor da célula A1 no dia 31/10/2017.

Desde já, agradeço a ajuda!!


#2

Ola @Iremar, cole isso na Workbook_Open da sua planilha…

Private Sub Workbook_Open()
Dim dtacao As Date
  
          'Escolha a data que deverá executar a ação
     dtacao = ("31/10/2017")
  
     If Date >= #1/11/2010# Then
     If Date >= dtacao Then
  
  'aqui a ação quando o retorno for verdadeiro
  ActiveSheet.Range("A2").Value = ActiveSheet.Range("A1").Value
     End If
     End If
End Sub

Segue anexo de exemplo…]

Ou tente com fórmula:

Insira isso na célula “A2”:

=SE(HOJE()=$J$1;A1;"")

Nesse exemplo estou inserindo a data para a execução em “J1” mas coloque a célula que você achar melhor.

Abrç!

Teste Agendamento.xlsm (12,9 KB)


#3

Bom dia,

Obrigado xlarruda. Usei a fórmula mesmo, funcionou perfeitamente!!

Valeu.