Seleção de dados classificados

Ola,

Simplificando, minha planilha tem nas colunas A e B, código e valor, respectivamente.

Em outro ponto de minha planilha, preciso pegar os códigos (coluna A) referentes aos três maiores valores (coluna B).

Os três maiores valores eu até consegui com a função MAIOR, mas como pegar os respectivos códigos na coluna A?

Obrigado.

Anselmo
Boa noite!
Use estas formulas para identificar
=ÍNDICE($A$2:$B$11;CORRESP(MAIOR($B$2:$B$11;1);$B$2:$B$11;0);1)
=ÍNDICE($A$2:$B$11;CORRESP(MAIOR($B$2:$B$11;2);$B$2:$B$11;0);1)
=ÍNDICE($A$2:$B$11;CORRESP(MAIOR($B$2:$B$11;3);$B$2:$B$11;0);1)
Adapte de acordo com sua coluna e linha
Fiz de outra forma como no exemplo caso o valor repita
SPP Maior valor e o índice do valor.xlsx (11,0,KB)

Valeu, Sebastião. Era exatamente o que eu precisava. Funcionou perfeitamente.

Obrigado pela dica.