Soma com valores até 9 ou 11, 22, 33, 44, 55


#1

Boa tarde,
Precisava por favor de uma ajuda a criar uma fórmula que somasse os valores de uma célula e que a soma desse de zero a nove ou se desse 11 ou 22 ou 33, 44, 55 ficasse esses valores como resultado.
Exemplo: valor da célula 911. A soma seria 9+1+1=11 e na outra célula apareceria o valor 11.
Neste momento uso estar fórmula:
=SE(RESTO(A1;9)=0;“9”;RESTO(A1;9)) (só dá para valores de 0 a 9)
Agora precisava de colocar a excepção do 11, 22, 33,…
Será que alguém me pode ajudar?
Consegui fazer apenas para o 11 mas falta ara 22, 33, 44, 55
=SE(A1=11;11;SE(RESTO(A1;9)=0;“9”;RESTO(A1;9)))
Um abraço


#2

Supondo que o valor esteja na celual B4 então

=SOMA(VALOR(EXT.TEXTO(B4;LIN($A$1:DESLOC($A$1;NÚM.CARACT(B4)-1;0));1)))

Lembrando é formula matricial tem que encerar com CTRL + SHIT + ENTER

Espero ter ajudado

Decio


#3

Grato pela ajuda.
Mas a designação da célula a1 para que serve?
Quando coloquei a fórmula apareceu #####


#4

Você deve terminar com CTRL + SHIT + ENTER pois é formula matricial, olha exemplo

Eu coloco célulaModelo Decio.xlsx (8,9 KB)
A1 só para ter sequencia 1,2,3, para separar o valor um a um para que depois posso somar.

Decio


#5

Grato pela ajuda.
Mas por exemplo se a célula tiver o valor 123, o resultado seria 1+2+3 seria 33 e não dá esse valor.
Um abraço


#6

Poste um modelo com os resultado pois o que eu entendi é a soma dos valores, não entendo o porque 11,22,33,44,55,… qual a regra???
Explica melhor

Decio


#7

Boa tarde,
O objectivo é pegar e somar os digitos de uma célula.
O segundo exemplo que dei foi errado desculpe.
Se o valor for por exemplo: 642, a formula irá fazer a soma 6+4+2=12=3
Por exemplo 9996=9+9+9+6=33
Logo o resultado será 33
A soma dos dígitos terá o resultado de 1 a 9 ou 11 ou 22 ou 33 ou 44


#8

Como você achou o numero 5 neste caso
Ou por exemplo 2552=2+5+5+2=14=5 (resultado final)

Como você achou o numero 3 neste caso
Se o valor for por exemplo: 642, a formula irá fazer a soma 6+4+2=12=3

Qual é a regra?

Decio


#9

A regra é somar os digitos da mesma célula.
Ou seja se a célula tiver o número 5113 na outra célula vai aparecer o valor 1.
Ou seja 5+1+1+3=10=1+0=1
Por tanto o objetivo é ficar com a unidade mas se o resultado for 11, 22, 33, 44 fica esse resultado.
Por isso é que tinha dito que o resultado seria de 0 a 9 ou 11 ou 22 ou 33 ou 44.


#10

Nos casos anteriores:
Ou por exemplo 2552=2+5+5+2=14=5 (resultado final)
Ou seja em uma célula(célula fixa) tem o valor 2552 e na outra faz a soma de todos os digitos
2+5+5+2=14 (resultado parcial) =1+4 =5 (resultado final)

Se o valor for por exemplo: 642, a formula irá fazer a soma 6+4+2=12=3
6+4+2=12 (resultado parcial) = 1+2 = 3

551=5+5+1=11 (resultado final)
6992=6+9+9+2= 26 = 2 + 6 = 8


#11

Então se entendi quando o primeiro resultado for 11,22,33,44,55,… fica esse valor mas se for diferente então soma novamente.

Isso esta correto?

Decio


#12

Confere se é desta forma, nota que usei uma coluna auxiliar e ocultei.

Decio

Modelo Decio 3.xlsx (10,5 KB)


#13

Gratidão pelo auxilio. Mas infelizmente continua a não dar certo. Por exemplo:
3336=3+3+3+6=15=6 mas na célula dá o resultado 3
6554=6+5+5+4=20=2 mas na célula dá o resultado 6


#14

Sim está correcto é mesmo isso. Se o valor for diferente de 11, 22, 33, 44, 55, soma-se os dois dígitos. Resultando em um número de 1 a 9.