Soma de números numa mesma célula


#1

Boa noite pessoal, tenho uma duvida e preciso da ajuda de vcs.

Tenho em 3 celulas com seguintes numeros:

243
729
2187

gostaria de somar os mesmos da seguinte forma sem ser manualmente:

2+4+3 = 9
7+2+9=18
2+1+8+7=18

Entao, que formula devo utilizar e como para realizar tal acao?

Grato!


#2

@renzofiori, considerando seu número na célula A1:

=VALOR("0"&EXT.TEXTO(A1;1;1))+VALOR("0"&EXT.TEXTO(A1;2;1))+VALOR("0"&EXT.TEXTO(A1;3;1))+VALOR("0"&EXT.TEXTO(A1;4;1))

Considerei como máximo de dígitos, 4. Para mais dígitos basta ir repetindo a sequência.


#3

Xavier, sou muito grato por sua ajuda.

Muito obrigado novamente.


#4

@renzofiori

Usa esta formula

=SOMARPRODUTO(–EXT.TEXTO(A1;LIN(INDIRETO(“1:”&NÚM.CARACT(A1)));1))

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio