Soma entre duas data com duas condição


#1

Boa Tarde!
O que esta errado nesta formula

Soma entre duas datas e duas condição.xlsx (13,2 KB)


#2

@SPP, há uma coluna de texto com condição numérica. A correção:

De:
=SOMASES(G9:G22;B9:B22;F2;C9:C22;">="&F3;D9:D22;"<="&G3;D9:D22;F4)
Para:
=SOMASES(G9:G22;B9:B22;F2;C9:C22;">="&F3;C9:C22;"<="&G3;D9:D22;F4)

Soma entre duas datas e duas condição.xlsx (12,3 KB)


#3

Segue uma alternativa que, particularmente coustumo usar e acredito ser menos embaralhado que o SOMASES.

=SOMARPRODUTO(($B$9:$B$22=$F$2)*($C$9:$C$22>=$F$3)*($C$9:$C$22<=$G$3)*($D$9:$D$22=$F$4)*$G$9:$G$22)

Cada critério dentro do seus próprios parenteses.


#4

Obrigado, Leonardo e Andre
As duas formula funcionaram perfeitamente