Somar células excluindo números duplicados


#1

Boa tarde
Preciso de uma função onde eu possa somar os valores da planilha mas se somar os valores duplicados. Resultado que quero é 510 e não 660 se eu fizer apenas a soma
Ex; A B
1 Tr 01 100
2 Tr 02 150
3 Tr 03 50
4 Tr 01 100
5 Tr 04 200
6 Tr 03 50
7 Tr 05 10
RESULTADO 510


#2

=SOMARPRODUTO(SEERRO(MENOR(SE(CORRESP($A$2:$A$8;A2:A8;0) = LIN(A2:A8)-LIN(A2)+1;$B$2:$B$8;"");LIN(A2:A8)-LIN(A2)+1);""))

Obs. Finalize com Ctrl + Shift + Enter

Somar_Exclusivos.xlsx (8,5 KB)


#3

Perfeito deu certinho, ajudou muito, Obrigado