Somase considerando duas colunas


#1

Bom dia.

Obrigado a todos que me ajudaram sempre, antes de mais nada.
Gostaria de acrescentar uma observação à minha planilha.

Na coluna “C” tenho o Tipo de Despesa: FIXA ou EXTRA
Na coluna “D” tenho o Responsável pela Despesa: CASA ou LOJA
Na coluna “E” tenho o Valor da Despesa

Na célula “A1” tenho escrito CASA e na célula “B1” a função =SOMASE(D:D;A1;E:E)
Na célula “A2” tenho escrito LOJA e na célula “B2” a função =SOMASE(D:D;A2;E:E)
Dessa forma, as despesas de CASA escritas na coluna “D” (cujo valor estão na coluna E) são somados e informados na célula B1. E todos as despesas da LOJA informadas na coluna “D”, são informadas em “B2”.

Precisava informar agora se essas despesas são FIXAS ou EXTRAS (que estão na coluna “C”)

Ficaria assim:
(célula A1/CASA - Fixo) - (célula b1; retornar os Valores de Despesas FIXAS de CASA)
(célula A2/CASA - Extra) - (célula b2; retornar os Valores de Despesas EXTRAS de CASA)
(célula A3/LOJA - Fixo) - (célula b3; retornar os Valores de Despesas FIXAS de LOJA)
(célula A4/LOJA - Extra) - (célula b4; retornar os Valores de Despesas EXTRAS de LOJA)

Obrigado a todos!


#2

Fala, @albertosilvarj. Tudo bem?

Existe uma função mais nova no Excel parecida com esta que você está usando. Ela permite utilizar mais de 1 critério de comparação para a soma. A função é a SOMASES. A sintaxe também é parecida, a única diferença é que, nela, o intervalo de soma vem primeiro. Ficaria assim:

=SOMASES(E:E;D:D;A1;C:C;"Fixo") 

Ou você pode utilizar uma outra célula como referência para a palavra fixo.

Abraços.


#3

Usei outra célula para fixo e matei.

Muito obrigado!


#4

Show de bola, @albertosilvarj.

Qualquer dúvida, lembre-se que o fórum está aqui.

Abraços.