Somases com data

Boa tarde Pessoal! Tudo bem?
Preciso de um fazer um SOMASES para somar os valores da coluna D(D2:D7), em função do nome (A2:A7), da cor(E2:E7) e das datas (B2:B7 e C2:C7).
Os nomes tem que ser igual a celular A9, a cor tem que ser igual a célula A8 e as datas da mesma linha precisam ser iguais, isto é (B2=C2, A2=$A$9 e E2=$A$8, soma-se o valor de D2, e assim linha por linha).
Ao fazer um SOMASES simples, verifiquei que os critérios nome e cor funcionam corretamente. Porém o critério data não é entendido como deveria ser.
Segue:
nome data1 data2 valor COR 0 0
a 05/11/19 05/11/19 100 PRETO 500 500
a 05/11/19 05/11/19 100 PRETO 500 500
a 05/11/19 05/11/19 100 PRETO 500 500
a 05/11/19 08/10/18 100 PRETO 0 0
a 05/11/19 05/11/19 100 PRETO 500 500
a 05/11/19 05/11/19 100 PRETO 500 500
PRETO 0 0 0 0 0 0
a 0 0 0 0 0 0

Todas células que contém “0” e “500” são resultado obtidos através da fórmula: =SOMASES($D$1:$D$7;$B$1:$B$7;$C$1:$C$7;$C$1:$C$7;$B$1:$B$7;$E$1:$E$7;$A$8;$A$1:$A$7;$A$9).
Repare que na linha 5 a data 2 é diferente da data 1. Desta forma, esse valor não deveria ter sido somado e todas as células com a fórmula, deveriam ter retornado o valor 500, já que todos os nomes e cor são iguais as referências A8 e A9.
Acontece também que em células diferentes, o valor da mesma fórmula assume um resultado diferente. Todas deveriam aparecer o mesmo resultado.
Peço encarecidamente ajuda de quem saiba solucionar meu problema de extrema importância!
Obrigado,
João Henrique

Bom dia!
Jhcosta16
Veja se desta forma que pretende
Coloque uma data em A10

=SOMASES($D$2:$D$7;$B$2:$B$7;$A$10;$C$2:$C$7;$A$10;$E$2:$E$7;$A$8;$A$2:$A$7;$A$9)

1 Curtida

Boa tarde!
SSP, agradeço o apoio, mas dessa forma a fórmula não faria sentido. O objetivo é que ele some o valor das linhas que contém datas iguais nas colunas B e C, e não em uma célula fixa. As datas variam conforme o nome e a cor.
Caso ainda consiga me ajudar, agradeço!
obrigado

Jhcosta16
Coloque esta fórmula em H2 e Arraste
=SE(B2=C2;"";B2)
Use esta outra fórmula
=SOMASES($D$2:$D$7;$H$2:$H$7;"";$E$2:$E$7;$A$8;$A$2:$A$7;$A$9)

1 Curtida

Jhcosta16 , Bom Dia.

Eu uso desta forma para contar

=SOMARPRODUTO(($A$2:$A$7=$A$9)($E$2:$E$7=$A$8)($B$2:$B$7=$C$2:$C$7))

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio

1 Curtida