Somases + validação de dados


#1

Gente!! Preciso de ajuda!

Estou tentando usar o SOMASES com duas opções de validação de dados, mas o resultado da fórmula ou da valor “FALSO” ou só soma uma lista.

=SE($C$2=“Todos”;SE($D$2=“Todas”;(SOMASES(Base!AE:AE;Base!K:K;‘Resumo de Itens’!B5));SOMASES(Base!AE:AE;Base!K:K;‘Resumo de Itens’!B5;Base!AF:AF;‘Resumo de Itens’!$C$2;Base!B:B;‘Resumo de Itens’!D2)))

C2 e D2 são as listas

Fico no aguardo!!!


#2

@L20, boas.

Podes postar o ficheiro ou um exemplo com o resultado esperado para tornar mais fácil entender o erro.

Obrigado.


#3

@L20

=SE(E($C$2="Todos";$D$2="Todas");SOMASE(Base!K:K;'Resumo de Itens'!B5;Base!AE:AE);SOMASES(Base!AE:AE;Base!K:K;'Resumo de Itens'!B5;Base!AF:AF;'Resumo de Itens'!$C$2;Base!B:B;'Resumo de Itens'!D2))