Substituições complexas


#1

Bom dia pessoal;

Eu sou um iniciante no Excel (tanto q nem sei se tem como colocar algo semelhante como um planilha no tópico) e estou com um problema que não sei como resolver.

No caso, eu tenho duas planilhas: a primeira tem uma lista de nomes e códigos, por exemplo:

1 João
2 Marcelo
3 Paula

E a outra tem algumas outras informações, entre elas o nome dos usuários da outra planilha:

João Pizza 20.00
João Lanche 12.00
João Burrito 8.00
Marcelo Lanche 10.00
Paula Água 2.00
Paula Pizza 22.00

Essas planilhas são só uns exemplos inventados, as que eu preciso alterar são bem maiores. Eu precisaria mudar os nomes que estão na segunda planilha para códigos de acordo com a primeira planilha. Ou seja:

1 Pizza 20.00
1 Lanche 12.00
1 Burrito 8.00
2 Lanche 10.00
3 Água 2.00
3 Pizza 22.00

Qual seria a maneira mais rápida de se fazer isso?


#2

@Breno_Novo, acho que um caminho mais simples seria primeiro encontrar os códigos na quarta coluna com as funções ÍNDICE e CORRESP como no exemplo:

=ÍNDICE(Planilha1!A:B;CORRESP(A1;Planilha1!B:B;0);1)

E posteriormente copiar (Ctrl+C) e colar valores na primeira coluna (botão direito do mouse, opção Colar valores).