Substituir um Hifen e recuperar apenas 6 digitos dessa mesma célula

Bom dia.

Estou a tentar construir uma Formula em que tenho que substituir um Hifen de uma referência, e ao mesmo tempo puxar um máximo de 6 digitos dessa referência a contar do lado direito.

Isto porque as referências são usadas para códigos de barra e este só pode ter no máximo 11 digitos. Sendo que estes 6 vão ser concatenados com outras informações.

A Formula que criei foi a seguinte:

=SE(CARÁT(SUBST(E4;"-";""))=6;DIREITA(E4;6);DIREITA(E4;6)&(SUBST(E4;"-";"")))

Como se pode ver na imagem. Está inconsistente no momento sendo que me devolve 10,11,12 digitos.

Será que me ajudam a ver onde estou a errar?

Cumprimentos

@Cardreaper, Boa Tarde

Seja bem vindo

Para pegar somente 6 caractere usa esta formula

=“M”&EXT.TEXTO(SUBSTITUIR(E4;"-";"");1;6)&“U”

Se quer pegar todo numero ate 11 caractere então usa esta formula

=“M”&EXT.TEXTO(SUBSTITUIR(E4;"-";"");1;9)&“U”

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio

2 Curtidas

Boas deixo aqui outra solução:

   =A1&B1&DIREITA(SUBSTITUIR(C1;"-";"");10-NÚM.CARACT(A1&B1))&E1
1 Curtida

Obrigado pela ajuda.
Esta Formula funciona

1 Curtida

Obrigado pela ajuda.

Esta Formula também funciona

1 Curtida