Tabela Dinamica - alimentos


#1

Bom dia amigos, estou montando uma dieta, e como o Excel serve para quase tudo, vou usa-lo para calcular calorias, nutrientes etc.

O que preciso é de uma tabela, na qual quando eu adiciono um numero na coluna QUANTIDADE ele some todos os dados da linha (correspondendo a quantidade digitada) aos outros itens da mesma coluna, também somente quando a QUANTIDADE for inserida. Segue exemplo para ficar mais fácil de entender.

Exemplo de tabela

Na linha TOTAL eu fiz as contas manualmente, mas esta é a parte que quero automatizar. Somei os itens de cada coluna, correspondendo ao valor digitado na coluna QUANTIDADE.

Caso ja tenha entendido pode pular esta parte. Outro exemplo para garantir o entendimento:
Exemplo de tabela 2

Acredito que esteja bem explicado, mas caso tenham duvidas perguntem a vontade
Agradeço desde já pela colaboração.


#2

Boas @gorlol3,

tenta com esta formula.

=+(C2M2)+(C3M3)+(C4M4)+(C5M5)+(C6*M6)


#3

@gorlol3, a função SOMARPRODUTO tem este poder:

=SOMARPRODUTO(B2:B6*$H2:$H6)


#4

Oi @gorlol3, acabamos nos inspirando pelo seu tópico e desenvolvemos uma planilha para dieta e controle de calorias. Tem um pouco dessa parte que você comentou aqui e umas outras mais relacionadas ao controle de peso mensal e painel de controle para análise. Veja se te ajuda mais - https://luz.vc/planilhas-empresariais/planilha-para-dieta-e-calculo-de-calorias-excel


#5

Deu como formula errada


#6

Deu certo! muito obrigado.


#7

Beleza, vou dar uma olhada.