Usando SE e E. Planilha de controle de RH


#1

Bom dia pessoal.
Estou fazendo uma lógica e estou com problemas. Podem me ajudar?!

A minha intenção é fazer uma lista de pessoas que foram admitidas numa empresa e de acordo com a data de admissão, retornar uma mensagem de:
Após 30 dias “Aplicar avaliação de experiencia”;
Apos 60 dias “Aplicar avaliação de experiencia”;
Apos 90 dias “Aplicar avaliação de experiencia” e
A cada ano (365 dias) “Aplicar avaliação periódica”. O meu problema está aqui. Rs…

Vou mostrar a logica que eu estou fazendo. Acredito ter forma mais simples de fazê-la, mas foi o melhor que consegui. Só não finalizei, porque parece que o excel tem limite de uso de SE e E. Certo?

Quem puder ajudar, vou ser muiiiiito grata. Obrigada.

Celula B3 (Data de admissão)
Celula D3 (Dia de Hoje - Data de Admissão)

Logica:
=SE(B3="";“Preencha as datas ao lado”;SE(E(D3<=59;D3>=30);“1ª Avaliação do período de experiência”;SE(E(D3<=89;D3>=60);“2ª Avaliação do período de experiência”;SE(E(D3<=120;D3>=90);“3ª Avaliação do período de experiência”;(SE(E(D3<=364;D3>=91);“Em dia”;(SE(E(D3<=375;D3>=365);“Avaliação periódica anual”;SE(E(D3<=729;D3>=376);“Em dia”;SE(E(D3<=740;D3>=730);“Avaliação periódica anual”;…)))))))))


#2

Ficaria mais claro que você postasse sua planilha


#4


#5

Nao consigo enviar arquivo em (.xls), somente (.jpeg). :confused:


#6

Não precisa . já vi aqui.


#7

Segue conforme pedido:

=SE(B3="";“Preencha as datas ao lado”;SE(E(D3<=59;D3>=30);“1ª Avaliação do período de experiência”;SE(E(D3<=89;D3>=60);“2ª Avaliação do período de experiência”;SE(E(D3<=120;D3>=90);“3ª Avaliação do período de experiência”;(SE(E(D3<=364;D3>=91);“Em dia”;(SE(E(D3<=375;D3>=365);“Avaliação periódica anual”;SE(E(D3<=729;D3>=376);“Em dia”;SE(E(D3<=740;D3>=730);“Avaliação periódica anual”;""))))))))))

Porém tem um problema:

Existem números nesse intervalo aqui que coicidem:

SE(E(D3<=120;D3>=90);“3ª Avaliação do período de experiência”;(SE(E(D3<=364;D3>=91)

Nesse caso o excel retorna a condição que vier primeiro.

Só respondendo: Não sei se o excel tem limites de SE, mas o erro foi que você informou vários textos caso a condição fosse verdadeira, mas se esqueceu do que o excel retornaria caso tudo fosse falso.


#8

Muito obrigada viu?! Eu concertei aqui.

Só uma coisinha, eu não consigo continuar deste ponto. Eu queria colocar até 5 anos rodando o periódico anual. Ficaria como na foto, porem, quando aperto Enter aparece essa mensagem no “E”: “A fórmula especificada não pode ser inserida porque ela usa mais níveis de aninhamento do que o permitido no formato de arquivo atual.”

Obrigada…


#9

Parece que eu consegui aqui. A mensagem é porque estava salva no excel versão 2003. Por enquanto, vou fazer os testes que parece que deu certo. Rs… Muito obrigada. :slight_smile: