Usar Função SE várias vezes na mesma célula


#1

Bom dia!

Colegas, estou criando um sistema de busca de dados e estou com problema em executar a ideia utilizando a função SE.

A ideia é a seguinte:

Tenho 6 campos que podem ser preenchidos, a cada campo preenchido o resultado é afinado. Exemplo:

Quero saber a quantidade de casos no Brasil;
Após, quero saber do Brasil, mas apenas da região nordeste;
Após, escolho o Estado e após a cidade, e após o bairro, após o dia da semana.

Tenho uma pasta de trabalho que é alimentada com essas informações.

Iniciei criando a seguinte fórmula:

=SE($T$23="";SE($M$23="";SE($G$23="";SE($Q$20="";SE($J$20="";CONT.SES(‘plan 1’!$E$16:$E$3000;$N$17;‘plan 1’!$B$16:$B$3000;A32);SE($T$23="";SE($M$23="";SE($G$23="";SE($Q$20="";CONT.SES(‘plan 1’!$E$16:$E$3000;$N$17;‘plan 1’!$F$16:$F$3000;$J$20;‘plan 1’!$B$16:$B$3000;A32);SE($T$23="";SE($M$23="";SE($G$23="";CONT.SES(‘plan 1’!$E$16:$E$3000;$N$17;‘plan 1’!$F$16:$F$3000;$J$20;‘plan 1’!$G$16:$G$3000;$Q$20;‘plan 1’!$B$16:$B$3000;A32)))))))))))))

Até esse ponto deu certo, que seriam o equivalente a refinar por Brasil e pelo Estado. Quando sigo o mesmo padrão (adicionando os () necessários) para refinar por cidade, ele não encontra a lógica e retorna #####.

https://mega.nz/#!EKAHWaAR!3ymelVM5TJlVzAxvm1OLxyGnDPKvwGIu_WEJ23UXtzg

Agradeço a ajuda!


#2

Poste sua planilha com um exemplo pois assim não dá pra saber se vai retornar o valor correto ou nao


#3

Tentei anexar mas, como sou novo usuário, não consegui.

Segue o link do arquivo:

https://mega.nz/#!EKAHWaAR!3ymelVM5TJlVzAxvm1OLxyGnDPKvwGIu_WEJ23UXtzg