Vazio ao invés de Zero


#1

tenho a fórmula:
=SEERRO(PROCV(F2;VALORES!$A$2:$B$25;2;FALSO);"")
quando resulta em zero gostaria que retornasse vazio?


#2

Fala, @quitomoreno.

=SEERRO(SE(PROCV(F2;VALORES!$A$2:$B$25;2;FALSO)=0;"";PROCV(F2;VALORES!$A$2:$B$25;2;FALSO));"")


#3

Bom dia Xavier,
Não deu certo, ele diz que você inseriu número excessivo de argumentos para esta função.
Quero que, quando F2 estiver vazia, A2 fique também vazia.
Devo ter explicado errado.


#4

Oi, @quitomoreno. Havia apenas faltado um fechamento de parênteses. Fiz a edição lá.


#5

Obrigado Xavier,
agora tenho mais 3 fórmulas para fazer o mesmo e estou com muita dificuldade,
principalmente porque a primeira é enorme.

=SOMA(‘PAG 1’!$E$7;‘PAG 1’!$E$10;‘PAG 1’!$E$13;‘PAG 1’!$E$16;‘PAG 1’!$E$19;‘PAG 1’!$E$22;‘PAG 1’!$E$25;‘PAG 1’!$E$28;‘PAG 1’!$E$31;‘PAG 1’!$E$34;‘PAG 2’!$E$7;‘PAG 2’!$E$10;‘PAG 2’!$E$13;‘PAG 2’!$E$16;‘PAG 2’!$E$19;‘PAG 2’!$E$22;‘PAG 2’!$E$25;‘PAG 2’!$E$28;‘PAG 2’!$E$31;‘PAG 2’!$E$34)

=B3*B4

=SOMA(B4:L4)


#6

=SEERRO(SE(SOMA(‘PAG 1’!$E$7;‘PAG 1’!$E$10;‘PAG 1’!$E$13;‘PAG 1’!$E$16;‘PAG 1’!$E$19;‘PAG 1’!$E$22;‘PAG 1’!$E$25;‘PAG 1’!$E$28;‘PAG 1’!$E$31;‘PAG 1’!$E$34;‘PAG 2’!$E$7;‘PAG 2’!$E$10;‘PAG 2’!$E$13;‘PAG 2’!$E$16;‘PAG 2’!$E$19;‘PAG 2’!$E$22;‘PAG 2’!$E$25;‘PAG 2’!$E$28;‘PAG 2’!$E$31;‘PAG 2’!$E$34)=0;"";SOMA(‘PAG 1’!$E$7;‘PAG 1’!$E$10;‘PAG 1’!$E$13;‘PAG 1’!$E$16;‘PAG 1’!$E$19;‘PAG 1’!$E$22;‘PAG 1’!$E$25;‘PAG 1’!$E$28;‘PAG 1’!$E$31;‘PAG 1’!$E$34;‘PAG 2’!$E$7;‘PAG 2’!$E$10;‘PAG 2’!$E$13;‘PAG 2’!$E$16;‘PAG 2’!$E$19;‘PAG 2’!$E$22;‘PAG 2’!$E$25;‘PAG 2’!$E$28;‘PAG 2’!$E$31;‘PAG 2’!$E$34));"")

Provavelmente você vai ter que redigitar as aspas simples.

=SEERRO(SE(B3*B4=0;"";B3*B4);"")

=SEERRO(SE(SOMA(B4:L4)=0;"";SOMA(B4:L4));"")


#7

Muito obrigado, me ajudou bastante.